Archive for fevereiro \02\UTC 2010

Os repositórios do KDE no openSUSE

Olá pessoal!

Segue a tradução de partes de um e-mail da lista opensuse-kde sobre o funcionamento dos repositórios do KDE no openSUSE, depois de muitas perguntas sobre os repositórios STABLE, UNSTABLE, FACTORY e KDE43:

LEIA ESTE RESUMO
Se tudo que você quer é uma versão funcional do KDE, fique com a que vem na distro quando você a instala. Tudo o mais poderá quebrar seu sistema a qualquer hora e sem aviso porque eles *sempre* estão mudando.

Se você quiser as últimas versões lançadas apenas dos aplicativos que não fazem parte do ‘núcleo do KDE’ (por ex.:
amarok e digikam) use o repositório KDE:Backports.

Se você quiser a última versão lançada (incluindo Betas e RCs) do KDE (área de trabalho e aplicativos) use o repositótio KDE:KDE4:Factory:Desktop.

Se o KDE fizer um lançamento quando o KDE:KDE4:Factory:Desktop estiver ocupado, a equipe do KDE pode escolher criar um repositório adicional (por ex.: KDE:42, KDE:43) para empacotar a última versão.

Assim que o KDE:KDE4:Factory:Desktop voltar a ficar liberado, estes repositórios adicionais irão *desaparecer*. Se você decidir que deve ter a última versão e alterar para os repositórios específicos, esteja avisado que eles irão desaparecer novamente em alguns meses.

* Isto significa que se você precisa ter a última versão do KDE sempre você terá que ALTERAR seus repositórios volta e meia, não há como mudar isto. O desenvolvimento para a próxima versão e não os usuários tem prioridade neste repositórios específicos. Para manter-se com o upstream você terá que mudar do KKFD para KDE:{versão} e de volta para o KKFD a cada poucos meses. *

Se você quiser tornar isto simples, fique com o KKFD até ele voltar a mover-se novamente.

Isto é tudo que você precisa saber por hora. Normalmente as únicas versões disponíveis do KDE que você pode esperar ter disponíveis são:
1) A versão que está no último lançamento da distro em STABLE
2) A versão para o próximo lançamento da distro em FACTORY
3) O ramo em desenvolvimento (bleeding edge/trunk) do KDE em UNSTABLE

Qualquer outro repositório é temporário e não há garantia que ele ainda esteja disponível amanhã. Se você usa um deles é seu trabalho estar alerta a qualquer alteração neles. Fique com os repositórios acima e tudo bem. Se você escolher usar um repositório temporário porque você *tem* que ter a última versão, não reclame do layout do repositório, a alternativa é não fornecer eles.
FIM DO RESUMO

…(descrição mais detalhada dos repositórios)…

Cordialmente,
Tejas

PS: Toda esta informação foi obtida ao ler as páginas da wiki

fontes: http://lists.opensuse.org/opensuse-kde/2010-01/msg00046.html (email original) e http://www.freetechie.com/blog/opensuse-kde-4-repositories-explained/ (post)